We are experiencing a technical issue
Incident Report for MailerSend
Postmortem

We experienced slowdowns in sendings, on our single and bulk email endpoints. This affected a few accounts for around 2 hours.

Our team investigated the issue and found that our sending servers had a memory leak. After the restart, the slowdowns were reduced, and the speed of sending went back to normal. For the past few weeks, we have been working on a more scalable sending infrastructure, and we plan to roll it out this week. This will address these problems so they do not happen again.

We understand you have emails to deliver, and an apology will not mean much right now. We wanted to be transparent and let you know that we are 100% focused on fixing the issue and improving our product.

Thank you for your understanding,
The MailerSend team

Posted Apr 15, 2024 - 21:28 EEST

Resolved
The technical issue has been resolved. The email sending are back to normal. Thank you so much for your patience.
Posted Apr 15, 2024 - 21:07 EEST
Update
We are continuing to investigate the issue. The /email endpoint is also showing signs of delayed sending. Emails are queued and sent, but the delivered event is being delayed.
Posted Apr 15, 2024 - 20:31 EEST
Investigating
We are experiencing a technical issue with bulk sending that cause a delay in email sending.

Our engineers are working hard to resolve the issue within the next couple of hours. We appreciate your patience.
Posted Apr 15, 2024 - 19:00 EEST
This incident affected: Email sending API.