We are experiencing a technical issue
Incident Report for MailerSend
Resolved
The technical issue has been resolved. The App is back to normal. Thank you so much for your patience.
Posted Jun 02, 2022 - 14:00 EEST
Monitoring
The issue has been temporarily fixed and is now being monitored, we are waiting for updates from our third-party service.

If you are still experiencing issues, please contact customer support via live chat or info@mailersend.com.
Posted Jun 02, 2022 - 13:37 EEST
Identified
The issue has been identified and has been caused by a third-party storage service provider. We are actively working on implementing a solution and will let you know when the fix has been released.
Posted Jun 02, 2022 - 13:31 EEST
Investigating
We are experiencing a technical issue causing email sending outage with API and SMTP as well as access to the whole app. All of our engineers are working hard to fix the issue as soon as possible.

We apologize for this downtime. We know that you have emails to deliver, so we're 100% focused on resolving this and preventing future issues. You can check the status page for regular updates.

Thank you for your understanding,
The MailerSend team
Posted Jun 02, 2022 - 13:28 EEST
This incident affected: MailerSend APP, Email sending API, SMTP, and Inbound routing.