We are experiencing a technical issue
Incident Report for MailerSend
Resolved
The incident was resolved, no emails have been lost during the process.
Posted Aug 26, 2022 - 15:30 EEST
Investigating
We are experiencing a technical issue in the MailerSend app: the dashboard is unavailable. Our team is working to fix the issue as soon as possible. We will update the status page as it's resolved. None of the other pages are affected and emails are still being processed.
Posted Aug 26, 2022 - 15:19 EEST
This incident affected: MailerSend APP.