The issue has been resolved
Incident Report for MailerSend
Postmortem

Users have faced a lot of 500 server errors from 2:46 am UTC on the morning of 10th Oct, 22. SRE has been paged at 4:31 am UTC and noticed it was a storage issue. The storage caused errors while creating new files in storage for cache or message content, etc.

Our SRE team started cleaning up the storage at 4:57 am UTC and put mitigation measures in place so storage utilization would be better managed and would send alerts in case of failure.

Posted Aug 10, 2022 - 11:03 EEST

Resolved
Users were facing 500 server errors on the API and SMTP connections and as a result, were unable to send some emails.

The issue has been resolved. Thank you so much for your patience. We sincerely apologize for the inconvenience. A full explanation of what happened is on the way.
Posted Aug 10, 2022 - 05:30 EEST