Technical issues
Incident Report for MailerSend
Postmortem

We experienced a technical issue in the MailerSend app that may have caused problems for some users. The issue has been fixed. We apologize for any inconvenience.

Posted Nov 24, 2021 - 14:07 EET

Resolved
We experienced a technical issue in the MailerSend app that may have caused problems for some users. The issue has been fixed. We apologize for any inconvenience.
Posted Nov 24, 2021 - 14:05 EET
Investigating
We are currently investigating this issue.
Posted Nov 24, 2021 - 11:45 EET
This incident affected: MailerSend APP, Email sending API, and Inbound routing.