We are experiencing a technical issue
Incident Report for MailerSend
Resolved
The problem should be resolved now, sorry for the inconvenience.
Posted Jun 04, 2024 - 14:20 EEST
Investigating
We are experiencing a technical issue with the deferrals for emails sent to Gmail domains that may prevent some users from delivering emails to certain Gmail recipients. The emails will be delivered normally once the issue is fixed.

Our engineers are working hard to resolve the issue within the next couple of hours (rough estimate). We are grateful for your patience.
Posted Jun 03, 2024 - 21:00 EEST
This incident affected: Deliverability rate.