Email status report issue.

Incident Report for MailerSend

Resolved

The incident has been resolved.
Posted Apr 10, 2025 - 13:41 EEST

Update

The fix has been deployed. The incident did not impact deliverability—it only caused an incorrect status label to be displayed. We’re currently monitoring and processing the queue successfully. All deliverability statuses are expected to be displayed correctly within the next 30 minutes.
Posted Apr 10, 2025 - 13:20 EEST

Monitoring

We have identified the fix and are monitoring
Posted Apr 10, 2025 - 11:39 EEST

Investigating

We're currently seeing an issue where the ​Delivered​ status isn't updating in MailerSend. Emails are still sending and delivering as expected — this is just a reporting issue.

Sorry for the confusion this might've caused! We're working on a fix and will update here once it's resolved.
Posted Apr 10, 2025 - 10:32 EEST
This incident affected: MailerSend APP.