We're experiencing a technical issue
Incident Report for MailerSend
Resolved
This incident has been resolved.
Posted Oct 27, 2022 - 03:26 EEST
Investigating
We are experiencing a technical issue that might cause some delays while using the app. All of our engineers are working hard to fix the issue as soon as possible.

We understand that you have emails to deliver and an apology will not mean much right now. But we wanted you to know that we are 100% focused on fixing the issue and ensuring this doesn’t happen in the future.

Thank you for your understanding,
The MailerSend team
Posted Oct 27, 2022 - 02:44 EEST
This incident affected: SMTP.