We are experiencing a technical issue
Incident Report for MailerSend
Resolved
The technical issue has been resolved. The App is back to normal. Thank you so much for your patience.
Posted Nov 17, 2022 - 10:31 EET
Update
We are working on a remedy, team will provide details at a later time.
Posted Nov 16, 2022 - 17:15 EET
Update
Analytics data is delayed at this time, our development team is working on a solution.
Posted Nov 16, 2022 - 12:22 EET
Update
Services are operational and we are monitoring the situation.
Posted Nov 16, 2022 - 02:12 EET
Update
We are applying measures to stop any further issues.
Posted Nov 15, 2022 - 20:17 EET
Monitoring
We reverted our latest release and continue monitoring any performance degradation. The activity page might have some latencies. Our team is still investigating what is causing it.
Posted Nov 15, 2022 - 17:05 EET
Update
We detected the problem with our latest release and the team is investigating what is causing it. We will update our status page as soon as we have more information.
Posted Nov 15, 2022 - 16:31 EET
Investigating
We are experiencing a technical issue in the MailerSend app that may affect some users. Our team is working to fix the issue as soon as possible. We will update the status page as it's resolved.
Posted Nov 15, 2022 - 16:30 EET
This incident affected: MailerSend APP and Email sending API.