We are experiencing a technical issue
Incident Report for MailerSend
Resolved
This incident has been resolved.
Posted Dec 03, 2024 - 17:11 EET
Investigating
We are experiencing a latency issue that may cause delays for some but not all users. Our engineers are working hard to resolve the issue. We are grateful for your patience.
Posted Dec 03, 2024 - 15:29 EET
This incident affected: Email sending API and SMTP.