We are experiencing a technical issue
Incident Report for MailerSend
Resolved
Deliverability rate should be back to normal.
Posted Jul 16, 2024 - 17:06 EEST
Monitoring
A fix has been implemented, new emails should not be deferred.
Posted Jul 16, 2024 - 16:34 EEST
Investigating
We are aware of an issue that is currently affecting our email delivery to GMail accounts. Due to a rate-limiting issue, emails sent to GMail addresses are being deferred, resulting in delays in delivery.

Our engineers are actively investigating the cause of this rate-limiting issue and are working diligently to resolve it as quickly as possible.

We understand the frustration and inconvenience this may cause, and we deeply apologize for any disruptions this issue may have created for you or your business.
Posted Jul 16, 2024 - 15:34 EEST
This incident affected: Deliverability rate.