Delayed delivery time
Incident Report for MailerSend
Resolved
The slowdown was absorbed.
Posted Feb 28, 2024 - 13:28 EET
Update
We are continuing to work on a fix for this issue.
Posted Feb 28, 2024 - 12:49 EET
Identified
Due to an unexpectedly high sending load, we're experiencing some delays in email delivery. Emails are still being sent. This should return to normal in a few minutes.
Posted Feb 28, 2024 - 12:43 EET
This incident affected: Email sending API and SMTP.