MailerSend

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Technical issues
Resolved·Partial outage
We’ve published a write-up of this incidentRead the write-up
Read it here
Affected components
Nov 24, 2021, 12:04 PM
12:05 PM
MailerSend APP
Inbound routing
Updates

Write-up published

Read it here

Resolved

We experienced a technical issue in the MailerSend app that may have caused problems for some users. The issue has been fixed. We apologize for any inconvenience.

Wed, Nov 24, 2021, 12:05 PM

Resolved

We experienced a technical issue in the MailerSend app that may have caused problems for some users. The issue has been fixed. We apologize for any inconvenience.

Wed, Nov 24, 2021, 12:05 PM

Investigating

We are currently investigating this issue.

Wed, Nov 24, 2021, 09:45 AM(2 hours earlier)